Skip to content

Missing flow outputs in deployment

Symptoms

You may experience this issue if some inputs or outputs are not available for mapping in the deployment configuration.

Causes

This issue can occur when a flow was updated with new or changed outputs or inputs.

Solutions

Remove and re-add the flow in the deployment configuration

If you updated a flow and the new inputs/outputs are not available for mapping, remove the flow in the deployment configuration and add it again.

  1. Open the affected deployment's configuration.

  2. Go to the tab that lists the flows used in the deployment.

    Deployment flow settings tab
    Flow settings tab with the cross icon to remove a flow.
  3. Click the cross icon next to the flow to remove it from the deployment.

  4. Click the plus icon to add the flow back to the deployment.

    Plus icon to add a flow to the deployment
    Plus icon to add a flow back to the deployment configuration.
  5. Map the outputs again using the updated flow outputs.

    Deployment dashboard output mapping
    Flow settings tab showing flow output mappings.

Expected result: The deployment configuration shows the updated flow outputs and you can map them correctly.